T O P
Zzyxzz

Because there is no solution. It's just a piece of garbage. Return it and buy a keyboard from a different brand. I had one 120 with that issue and a 121. Both failed with the same issue! My Kone Pure is now also fkd up after 1 year of use! I still have a mouse from razer and steelseries, they still work and are both 10 years and 5 years old. Roccat has really incredible low quality. Every product i bought is broken.


Zwiebeljochem

I had the exactly same problem with my vulcan 121! I pulled down the keycaps of W, E and Space (my problem childs) and blew hard into the Switches while pressing them down multiple times. My words sound a little bit like the words of a pervert but it fixed the problem and it didn't come back yet. Hope I can help


SR4Nova

Hmm. I used a power duster on the board with all the caps removed, but I didn't try actuating the keys while doing so. I'll give this a try, thank you!


Zwiebeljochem

I pushed them hard and often Why does everything I write in english sound so sexual..


Zwiebeljochem

Did it work for you? :)


SR4Nova

Sorry! I didn't mean to take so long to get back to you. I used a can of air and pointed it inside the switch. It seems to have helped a little, so I assume there's a dirty contact in it. This wouldn't surprise me as my environment is fairly dusty (lots of fields nearby). Thank you for your help!


adhauz

Exact same thing, dust ingress. It's not a piece of garbage. [https://www.reddit.com/r/Roccat/comments/dnsub8/solved\_the\_key\_not\_registering\_and\_double\_typing/](https://www.reddit.com/r/Roccat/comments/dnsub8/solved_the_key_not_registering_and_double_typing/)


SR4Nova

Yes. Since my posts and the advice given by [Zwiebeljochem](https://www.reddit.com/user/Zwiebeljochem/) I have successfully gotten my keys to respond properly, and the double letters have almost stopped completely. I used a whole can across several keys, and intend to give another treatment to the doubling keys when I can get more. A bit of maintenance is a small cost for this beautiful board.


Cobra38

I know i am a bit late to the party. But pressing FN+Game Mode fixed it.... Do not know why lol